Ordneraktion funktioniert manchmal nicht.

Von AppleSkript & Automator bis hin zu Objective C

Ordneraktion funktioniert manchmal nicht.

Beitragvon WalterBeiter » Sa 19. Jul 2014, 18:18

Hallo Leute.

Ich habe mir einen tollen Arbeitsablauf gemacht, der mir RAR und ZIP Dateien auf den Schreibtische verschiebt, entpackt und das Archiv löscht.

Leider funktioniert diese Ordneraktion nicht immer. Und ich weiß nicht warum.
Der Arbeitsablauf ist richtig.
Ich kann es testen und ein Bildschirmfoto komprimieren und in den Ordner schieben. Es wird entpackt und das Archiv gelöscht. Leider funktioniert das nicht, mit anderen Dateien, die ebenfalls ZIP sind. RAR ging bis jetzt so weit ich weiß immer ohne Probleme.

Hier sind ein paar Screenshots:
Benutzeravatar
WalterBeiter
Besucher
Besucher
 
Beiträge: 53
Registriert: Do 6. Jun 2013, 10:00

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon MasterOfDesaster » So 20. Jul 2014, 00:04

Was ich mich spontan frage: Ist die zweite Aktion zum Filtern wirklich notwendig?
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon WalterBeiter » So 20. Jul 2014, 12:03

Ja, denn er soll die DMGs ja nicht öffnen. Ich hatte das auch schon separat. Also eine weitere Ordneraktion, die mir einfach nur die DMGs verschiebt.
Aber auch als ich das separat hatte, hat es nicht immer funktioniert.
Weiß jemand zufällig, in welchem Abstand das Apple Script den Ordner nach Dateien prüft?
Benutzeravatar
WalterBeiter
Besucher
Besucher
 
Beiträge: 53
Registriert: Do 6. Jun 2013, 10:00

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon MasterOfDesaster » So 20. Jul 2014, 13:27

Weil ich gerade deine Schreibweise von .dmg sehe: Ist das vielleicht case-sensitiv (also .dmg und .DMG werden nicht gleich behandelt)?
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon WalterBeiter » So 20. Jul 2014, 21:25

Da bräuchte ich mal ein paar Testdateien, ich habe die ZIP Dateien nicht mehrm die nicht funktionierten (brauchte den Inhalt)
Wo kriege ich so Testdateien her? Ich weiß nur, wie ich normale zips machen kann mit rechte maus und dann komprimieren.
Benutzeravatar
WalterBeiter
Besucher
Besucher
 
Beiträge: 53
Registriert: Do 6. Jun 2013, 10:00

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon MasterOfDesaster » So 20. Jul 2014, 21:32

Einfach warten bis es wieder auftritt und dann mal auch die ZIP-Datei sichern.
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon sedl » So 20. Jul 2014, 21:40

Moin,

waren die zip Datein die nicht gingen vielleicht Passwort geschützt? Ansonsten sieht das alles so aus als ob es gehen müsste.

Alternativ. kannst du ja den Zweiten teil mal in einen eigenen Worflow legen der am Ende des ersten Teils durch eine Aktion gestartet wird. Dann müsstest du natürlich dem Zweiten teil als Ort der durscuht werden soll deinen Schreibtisch angeben. Ich hoffe das war verständlich.

gruss

sedl
sedl
Moderator
Moderator
 
Beiträge: 10313
Registriert: Di 31. Aug 2004, 08:43
Wohnort: Zuhause

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon WalterBeiter » So 20. Jul 2014, 21:51

Zips ware nicht passwortgeschützt. Leider hat der arbeitsablauf die zips nicht mal auf den schreibtisch verschoben.
Komiherweise ging eine test zip die ich am mac gemacht habe sofort als ich sie in den ordner verschoben habe. Nur die anderen zips, die in dem ordner drin waren, blieben da und wurden nich verändert.
Benutzeravatar
WalterBeiter
Besucher
Besucher
 
Beiträge: 53
Registriert: Do 6. Jun 2013, 10:00

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon sedl » So 20. Jul 2014, 21:56

Ah, hast du mal statt Finder Objekte filtern Finder Objekt suchen ausprobiert?
sedl
Moderator
Moderator
 
Beiträge: 10313
Registriert: Di 31. Aug 2004, 08:43
Wohnort: Zuhause

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon MasterOfDesaster » So 20. Jul 2014, 21:57

Probier mal die angehängte Datei aus, dann wissen wir ob es an der Groß- und Kleinschreibung lag.
Ich könnte mir sonst nur noch vorstellen, dass es ein Unterschied macht wo die Datei herkommt. Etwa ob du sie im Finder darein ziehst oder in Safari eine Datei mit dem Rechtsklick "Verlinkte Datei herunterladen" dort hinein beförderst (obwohl eigentlich beides gehen sollte).
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon WalterBeiter » Mo 21. Jul 2014, 18:51

Also folgendes: Ich habe einige Tests durchgeführt. Es ist sehr komisch. Es liegt nicht an der Schreibweise. ZIPs gehen auch.
Wenn ich relativ schnell hintereinander ZIPs in den Ordner verschiebe, kann es sein dass er nur 80% der Dateien entpackt. Die anderen werden übersehen. Selbst wenn man dann weitere Dateien in den Ordner schiebt, werden die alten weiterhin übersehen.
Manchmal ist eine starke Verzögerung vorhanden (10 Sekunden) manchmal ist keine Vorhanden.
Wenn man viele Dateien von dem Desktop auf einmal in den Ordner schiebt, werden alle Dateien entpackt. Wenn ich schnell nacheinander Dateien runterlade, werden nicht alle entpackt.
Ich konnte weder die Verzögerung beeinflussen (selbst bei 20 Downloads in 5 Sekunden ging es sehr schnell) noch wann und ob er die Dateien überhaupt entpackt.
Wenn es allerdings einmal nicht richtig ging, ging es danach für eine Weile (2-3 Minuten) nicht. Nicht mal einzelne neue Dateien wurden in der zeit entpackt.
Benutzeravatar
WalterBeiter
Besucher
Besucher
 
Beiträge: 53
Registriert: Do 6. Jun 2013, 10:00

Re: Ordneraktion funktioniert manchmal nicht.

Beitragvon WalterBeiter » Mo 21. Jul 2014, 19:04

Problem gelöst:

Ich habe das mit dem Suchen ausprobiert. Hat etwas besser geklappt. Also habe ich eine zweiter Ordneraktion gemacht, die das gleiche macht, wie die andere nur halt mit dem "Finder-Objekte suchen" Befehl funktioniert.
Jetzt hat es sehr gut geklappt.

Etwa 80 mal die Datei hier aus dem Thread in 50 Sekunden runtergeladen, verschoben und entpackt und das Archiv entsorgt.
Allerdings nicht alle auf einmal, Die Hälfte war nach etwa 15 Sekunden schon, dann hat es noch mals gedauert, wo er nichts gemacht hat, und dann hat er den Rest gemacht.

Ich denke dieses Thema ist abgeschlossen. Vielen Dank für die vielen Tips und die Unterstützung.

Automator ist immer noch sehr beliebt, wie ich sehe.
Benutzeravatar
WalterBeiter
Besucher
Besucher
 
Beiträge: 53
Registriert: Do 6. Jun 2013, 10:00


Zurück zu Skripte & Programmierung