Start im gesicherten Modus

Das Mac-System von seinen Anfängen bis Mac OS X

Start im gesicherten Modus

Beitragvon schwalenberg_188287 » Mo 17. Sep 2018, 09:52

Hallo,

ich möchte den iMac im gesicherten Modus starten. Dies gelingt mir leider nicht. Trotzdem ich die Umschalt-Taste beim Starten gedrückt halte, lande ich immer im "normalen" Modus. Woran könnte das liegen?

Ich benutze einen iMac mit Bluetooth Tastatur und der Version 10.13.6.

Ich habe alle externen Geräte entfernt, die Batterien in der Tastatur ausgewechselt, die Umschalt-Taste vor dem Start-Signals gedrückt, während des Start-Signals und auch kurz danach.

Auch beim Start mit der gedrückten "D" Taste (Hardware Test) passiert nichts. Ich lande immer im normalen Modus.

Was tun?

Viele Grüße
Steffi
schwalenberg_188287
Besucher
Besucher
 
Beiträge: 5
Registriert: Mo 17. Sep 2018, 09:44

Re: Start im gesicherten Modus

Beitragvon MasterOfDesaster » Di 18. Sep 2018, 16:21

Also der richtige Zeitpunkt ist auf jeden Fall direkt nach dem Startton.
Hast du vielleicht ein Firmware-Passwort gesetzt? Das blockiert manche Tastenkombinationen und muss dann zwischenzeitlich deaktiviert werden.
Es könnte natürlich auch irgendwie an der Bluetooth-Tastatur liegen. Dafür wäre es hilfreich zu wissen, ob zumindest die Tastenkombination [cmd][R] für dem Start im Wiederherstellungsmodus funktioniert.
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Start im gesicherten Modus

Beitragvon schwalenberg_188287 » Mi 19. Sep 2018, 08:06

Vielen Dank für deine Antwort. Nein, ich habe kein Firmware-Passwort vergeben. Die Tastenkombination "cmd" und "R" funktioniert auch nicht. Lande immer im Modus "normal".
schwalenberg_188287
Besucher
Besucher
 
Beiträge: 5
Registriert: Mo 17. Sep 2018, 09:44

Re: Start im gesicherten Modus

Beitragvon MasterOfDesaster » Mi 19. Sep 2018, 11:22

Das Problem scheint also ziemlich sicher mit der Bluetooth-Verbindung zusammenzuhängen.

Du kannst beim Drücken der Tasten versuchen vielleicht noch etwas zu warten bis du die Kombination drückst und so die Bluetooth-Verbindung doch da ist.

Wenn du noch eine Kabeltastatur rumliegen hast, dann kannst du es mal mit der versuchen.

Sonst ist die Frage, ob du im normalen Modus als Admin in das Terminal kommst (das mit dem abgesicherten Modus hat ja vermutlich einen Grund). Wenn ja, könntest du auch von dort einen Neustart im abgesicherten Modus einleiten.
Das würde dann mit der folgenden Terminal-Befehl gehen:
Code: Alles auswählen
sudo nvram boot-args="-x"
Anschließend, wenn du wieder im normalen Modus starten willst, folgenden Befehl eingeben:
Code: Alles auswählen
sudo nvram boot-args=""
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Start im gesicherten Modus

Beitragvon schwalenberg_188287 » Mi 19. Sep 2018, 13:05

Auch das will nicht klappen. Das Terminal fragt nach meinem Accountpasswort. Ich gebe das Passwort ein und bekomme folgenden Fehler:
nvram: Error setting variable - 'boot-args': (iokit/common) general error
iMac:~
schwalenberg_188287
Besucher
Besucher
 
Beiträge: 5
Registriert: Mo 17. Sep 2018, 09:44

Re: Start im gesicherten Modus

Beitragvon MasterOfDesaster » Mi 19. Sep 2018, 13:33

Da scheint ein Sicherheitsfeature das zu verhindern. Ein Umweg, der vielleicht noch gehen könnte, wäre erst mit dem folgenden Befehl in den Wiederherstellungsmodus zu starten und dort dann in Terminal, den Befehl aus den vorherigen Post einzugeben (zum Deaktivieren ebenso):
Code: Alles auswählen
sudo nvram "recovery-boot-mode=unused"
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Start im gesicherten Modus

Beitragvon schwalenberg_188287 » Do 20. Sep 2018, 08:09

Erstmal Danke für deine Antworten!

Wenn ich den Befehl zum Wiederherstellungsmodus ins Terminal eingebe, dann werde ich wieder nach meinem Passwort gefragt. Dies kann ich eingeben ohne einen Fehler zu bekommen. Dann passiert nichts. Dann gebe ich den Befehl für den abgesicherten Modus ein. Geht diesmal ohne Passwortabfrage. Dennoch bekomme wieder folgenden Fehler:
nvram: Error setting variable - 'boot-args': (iokit/common) general error
iMac:~

Wenn den Umweg gehe und den Befehl zum Wiederherstellungsmodus über Terminal/Shell/neuer Befehl eingebe, erscheint folgender Fehler:
Password:
-sudo: nvram: command not found
[Prozess beendet]
schwalenberg_188287
Besucher
Besucher
 
Beiträge: 5
Registriert: Mo 17. Sep 2018, 09:44

Re: Start im gesicherten Modus

Beitragvon mac-christian » Do 20. Sep 2018, 09:18

schwalenberg_188287 hat geschrieben:Wenn ich den Befehl zum Wiederherstellungsmodus ins Terminal eingebe, dann werde ich wieder nach meinem Passwort gefragt. Dies kann ich eingeben ohne einen Fehler zu bekommen.

Dann war das Passwort richtig. Sonst käme eine Fehlermeldung "Sorry, try again".

schwalenberg_188287 hat geschrieben:Dann passiert nichts.

Nichts, was du siehst. Vermutlich wurde die Änderung ins NVRAM geschrieben, aber es gibt keine (Miss-)Erfolgsmeldung. Ich nehme nicht an, dass die Änderung des NVRAM eine Meldung ausgibt, wenn sie erfolgreich war.

Warum hast du nicht in diesem Moment einen Neustart versucht?

schwalenberg_188287 hat geschrieben: Dann gebe ich den Befehl für den abgesicherten Modus ein. Geht diesmal ohne Passwortabfrage. Dennoch bekomme wieder folgenden Fehler:
nvram: Error setting variable - 'boot-args': (iokit/common) general error

Das heisst, du machst deine vorherige Änderung gleich wieder rückgängig und gibst die alte ein, die offensichtlich nicht geht?

Die Passwortabfrage kommt deshalb nicht, weil sich der Mac beim sudo das Passwort eine (kleine) Zeit lang merkt und nicht neu fragt.

schwalenberg_188287 hat geschrieben: Wenn den Umweg gehe und den Befehl zum Wiederherstellungsmodus über Terminal/Shell/neuer Befehl eingebe, erscheint folgender Fehler:
Password:
-sudo: nvram: command not found
[Prozess beendet]

Wer hat dir dieses Vorgehen empfohlen? Das öffnet bei mir einfach ein neues Terminalfenster und führt den Befehl da drin aus (eben ausprobiert). Wozu man das brauchen könnte statt direkt im Terminalfenster den Befehl einzugeben, ist mir unverständlich. Aber das "- "vor dem "sudo" musst du ja schon selber eingegeben haben, sonst hätte es der Mac nicht zitiert bei der Fehlermeldung..
Benutzeravatar
mac-christian
Veteran
Veteran
 
Beiträge: 2829
Registriert: Sa 9. Okt 2004, 20:50
Wohnort: Helvetien

Re: Start im gesicherten Modus

Beitragvon MasterOfDesaster » Do 20. Sep 2018, 10:04

Da habe ich mich vielleicht nicht klar genug ausgedrückt.
Nach dem ersten Befehl musst du selber neustarten um im Wiederherstellungsmodus zu landen.
Das Terminal in diesem Modus, das dort über die Menüleiste zu finden ist, hat mehr Befugnisse.
Entsprechend brauchst du dort auch übrigens nicht das Wort "sudo" vor dem Wort "nvram" eingeben.
MasterOfDesaster
Veteran
Veteran
 
Beiträge: 2481
Registriert: So 10. Feb 2008, 13:28

Re: Start im gesicherten Modus

Beitragvon schwalenberg_188287 » Do 20. Sep 2018, 10:14

Ja, daran hat es gelegen, ich habe nicht geblickt, dass ich den Befehl zum Neustart dann auch noch eingeben muss ;-) Dann hat´s gleich geklappt :-)

Vielen Dank!
schwalenberg_188287
Besucher
Besucher
 
Beiträge: 5
Registriert: Mo 17. Sep 2018, 09:44


Zurück zu Mac OS X & Classic